[Logwatch] Syntax error

Erik Ogan erik@slackers.net
Fri, 26 Jul 2002 09:14:39 -0700


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

KH6GMP ON ROADRUNNER wrote:
| Syntax error at /etc/log.d/scripts/services/sudo line 16, near ''require
| v5.6"
| Use of reserved work "our" is deprecated at
| /etc/log.d/scripts/services/sudo Line 18.

	The "sudo" logwatch parser currently requires perl >= 5.6.

	Looking at it, It would be fairly easy to move that
	requirement back down to 5.005.

	If you don't use sudo(*) you could remove
	/etc/log.d/conf/services/sudo

	I also want to pose a question to the community at large:
	There is something to be said for writing for the lowest
	common denominator perl version, but what version is too
	low (I'll be the first to admit that requiring 5.6 might be
	a bit aggressive, but versions before 5.005 some severe
	known issues. And 5.6 added some rather fundamental features
	(again, IMNSHO))

	What do other people think?

- -e

(*) IMNSHO, there aren't any good reasons not to use sudo, only excuses.

- --
Erik R. Ogan                                    Mercenary Developer
PGP Key:         http://erik.ogan.net/PGP.txt            0 o . _O-d
PGP Fingerprint: A3DB 678A 4737 32E7 F703  DC3A 6BFE 2BBC 4F41 A371

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQE9QXVva/4rvE9Bo3ERApAxAJ988JvetUQiFJCyfwgVx28gb9eRhACghtw9
bW5DOTBYC8u5aMjVuCZD4ws=
=ZB+2
-----END PGP SIGNATURE-----