[Logwatch] no output from logwatch

i@7505.com i@7505.com
Mon, 7 Oct 2002 13:21:05 -0700


first - thanks for the very cool product. 

I cannot seem to get logwatch to produce any output - either to stdout, a file or email. It is installed in the default /etc/log.d on a slackware 8.1 machine running perl v5.6.1. 

on running logwatch i get the following output:

chgrp: getting attributes of `11': No such file or directory
chgrp: getting attributes of `10': No such file or directory
chgrp: getting attributes of `6': No such file or directory
chgrp: getting attributes of `4': No such file or directory
chgrp: getting attributes of `3': No such file or directory
chgrp: getting attributes of `2': No such file or directory
chgrp: getting attributes of `1': No such file or directory
chgrp: getting attributes of `0': No such file or directory


and with debug set to 'High' the following output to a file/email:


 ################## LogWatch 3.3 Begin #####################

DEBUG: Inside OnlyService for automount
DEBUG: Inside OnlyService for dhcpd
DEBUG: Inside OnlyService for ftpd
DEBUG: Inside OnlyService for identd
DEBUG: Inside OnlyService for init
DEBUG: Inside OnlyService for kernel
DEBUG: Inside OnlyService for modprobe
DEBUG: Inside OnlyService for mountd
DEBUG: Inside OnlyService for named


DEBUG: Inside Named Filter

DEBUG: Inside OnlyService for pam
DEBUG: Inside OnlyService for pam_pwdb
DEBUG: Inside OnlyService for portsentry
DEBUG: Inside OnlyService for proftpd
DEBUG: Inside OnlyService for sshd


DEBUG: Inside SSHD Filter

DEBUG: Inside OnlyService for sshd2
DEBUG: Inside OnlyService for syslogd


 ###################### LogWatch End #########################


am i missing something very obvious here?

thanks for you help in advance,

greg