[Logwatch] Logwatch on Slackware 9.1

Dino Nardini dino@rivendellsoftware.com
Thu, 04 Dec 2003 10:59:33 -0400


Hello there,

You must move the /lib directory under /etc/log.d as well.  It contains the 
Logwatch.pm file, which you are missing.

Cheers... Dino


At 09:24 AM 04/12/2003 -0500, Jared Priddy wrote:
>Is ths supported?
>
>I created the directory /etc/log.d and moved the conf/ and scripts/ there
>per the instructions, and changed the mailer in logwatch.conf to match my
>system and changed use MkTemp to no.  I wanted to test it so I ran
>logwatch.pl from the command line.  I opened /var/log/messages, and noticed
>that logwatch had marked the files, but root never recieved the output in
>its mailbox.
>
>So I ran logwatch with these options
>
>/usr/sbin/logwatch --detail 10 --logfile messages --debug 10 --save
>output.txt
>
>Most of the services did not have any entries in the output file (as
>expected since this is a new system) but the ones on which I expected log
>entries I recieved errors instead.  For example, sshd:
>
>  --------------------- SSHD Begin ------------------------
>
>DEBUG: Inside OnlyService for sshd
>Can't locate Logwatch.pm in @INC (@INC contains: /etc/log.d//lib
>/usr/lib/perl5/5.8.0/i486-linux /usr/lib/perl5/5.8.0
>/usr/lib/perl5/site_perl/5.8.0/i486-linu
>x /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at
>/etc/log.d/scripts/services/sshd line 14.
>BEGIN failed--compilation aborted at /etc/log.d/scripts/services/sshd line
>14.
>
>  ---------------------- SSHD End -------------------------
>
>
>Line 14 of scripts/services/sshd is
>
>     use Logwatch ':all';
>
>I got the same type of output for named and portsentry (which aren't
>installed), mountd and pam_unix.
>
>Thanks...
>
>Jared
>
>_______________________________________________
>Logwatch mailing list
>Logwatch@logwatch.org
>http://www2.list.logwatch.org:81/lists/listinfo/logwatch

_____________________________________
Rivendell Software - Dynamic Web Solutions
http://www.rivendellsoftware.com
Tel 902.461.1697
Fax 902.461.3765