[Logwatch] logwatch feature request and packaging changes

Norrin Radd datadan_1@yahoo.com
Mon, 15 Dec 2003 06:56:33 -0800 (PST)


--0-1147322128-1071500193=:93910
Content-Type: text/plain; charset=us-ascii

In my /etc/log.d/scripts/services/sendmail
I have the following exclusions assigned:

while (defined($ThisLine = <STDIN>)) {
    if ( ( $ThisLine =~ m/^[a-zA-Z0-9]+: to=.*stat=/ ) or
         ( $ThisLine =~ m/^alias database [^ ]* (auto)?rebuilt by/ ) or
         ( $ThisLine =~ m/^[^ ]*: [0-9]* aliases, longest [0-9]* bytes, [0-9]* bytes total/ ) or
         ( $ThisLine =~ m/^starting daemon (.*):/ ) or
         ( $ThisLine =~ m/^[a-zA-Z0-9]+: Milter: data, discard/ ) or
         ( $ThisLine =~ m/^[a-zA-Z0-9]+: discarded/ ) or
         ( $ThisLine =~ m/^[a-zA-Z0-9]+: X-Antivirus: Scanned by F-Prot/ ) or
         ( $ThisLine =~ m/^[a-zA-Z0-9]+: X-Antivirus-Summary: Mod score: 0/ ) or
         ( $ThisLine =~ m/^[a-zA-Z0-9]+: clone [a-zA-Z0-9]+, owner=/ ) ) {

Yet I still see X-Antivirus: Scanned by F-Prot and X-Antivirus-Summary: Mod score: 0 appearing in my logwatch email.  I have stopped/started cron seval times.
What am I missing?
Thanks

 

---------------------------------
Do you Yahoo!?
New Yahoo! Photos - easier uploading and sharing
--0-1147322128-1071500193=:93910
Content-Type: text/html; charset=us-ascii

<DIV>In my /etc/log.d/scripts/services/sendmail</DIV>
<DIV>I have the following exclusions assigned:<BR></DIV>
<DIV>while (defined($ThisLine = &lt;STDIN&gt;)) {<BR>&nbsp;&nbsp;&nbsp; if ( ( $ThisLine =~ m/^[a-zA-Z0-9]+: to=.*stat=/ ) or<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ( $ThisLine =~ m/^alias database [^ ]* (auto)?rebuilt by/ ) or<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ( $ThisLine =~ m/^[^ ]*: [0-9]* aliases, longest [0-9]* bytes, [0-9]* bytes total/ ) or<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ( $ThisLine =~ m/^starting daemon (.*):/ ) or<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ( $ThisLine =~ m/^[a-zA-Z0-9]+: Milter: data, discard/ ) or<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ( $ThisLine =~ m/^[a-zA-Z0-9]+: discarded/ ) or<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ( $ThisLine =~ m/^[a-zA-Z0-9]+: X-Antivirus: Scanned by F-Prot/ ) or<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ( $ThisLine =~ m/^[a-zA-Z0-9]+: X-Antivirus-Summary: Mod score: 0/ ) or<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; (
 $ThisLine =~ m/^[a-zA-Z0-9]+: clone [a-zA-Z0-9]+, owner=/ ) ) {<BR><BR>Yet I still see X-Antivirus: Scanned by F-Prot and X-Antivirus-Summary: Mod score: 0 appearing in my logwatch email.&nbsp; I have stopped/started cron seval times.</DIV>
<DIV>What am I missing?</DIV>
<DIV>Thanks<BR></DIV>
<BLOCKQUOTE class=replbq style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #1010ff 2px solid">&nbsp;</BLOCKQUOTE><p><hr SIZE=1>
Do you Yahoo!?<br>
<a href="http://pa.yahoo.com/*http://us.rd.yahoo.com/evt=21260/*http://photos.yahoo.com">New Yahoo! Photos - easier uploading and sharing</a>
--0-1147322128-1071500193=:93910--