[Logwatch] applystddate - POSIX error

John S. Robinson J.S.Robinson at soton.ac.uk
Sat Dec 10 05:43:55 MST 2005


Hi,

I'm using Logwatch on RHEL 4.0.  RPM reports the version as:

logwatch-5.2.2-1.EL4.1

I'm getting the following error (repeated 10+ times) when I run Logwatch...


/etc/cron.daily/00-logwatch:

Can't declare array dereference in "our" 
at /usr/lib/perl5/5.8.5/i386-linux-thread-multi/POSIX.pm line 3, near ") ="
BEGIN not safe after errors--compilation aborted 
at /usr/lib/perl5/5.8.5/i386-linux-thread-multi/POSIX.pm line 7.
Compilation failed in require at /etc/log.d/scripts/shared/applystddate line 
14.
BEGIN failed--compilation aborted at /etc/log.d/scripts/shared/applystddate 
line 14.



...I've tried reinstalling the RPM, but the problem remains, I've also checked 
and the Perl POSIX.pm doesn't seem corrupted.  Curiously, none of my other 
RHEL 4.0 systems suffer this problem.  Can anyone suggest where to start 
looking?

Thank in advance,

John R.


More information about the Logwatch mailing list