[Logwatch] Logwatch-CVS & Cron

Ann Hopkins seashell at handypaws.com
Wed Aug 30 19:35:30 MST 2006


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Okay I tried a lot of things since I sent this email message and I
still don't understand what I found out.

I tried this on SuSE 10.1 Logwatch-CVS on a new machine,
my old machine is SuSE 9.1 using Logwatch-CVS which is what I was
comparing it.

Cron (Standard) Updated (Source Compiled)
Cron (Standard) (OS Version)
Fcron (Source Compiled)

Perl 5.8.8 (Source Install)
Perl 5.8.8 (OS Version)


And every single combination will die if you run it under any of the
 schedulers with the weird 'cat' error somewhere down the line.

I remembered something that always seemed to work which was the
"--logfile" option.  I tried every known combination and eventually
the only file that will fail is "cron"  either as a service or a
logfile option.

I don't know what is different on this OS, but if I remove "cron" as
an option it works fine.

Does anyone have a reasonable explanation?

I mean basically - command line is okay, but under "cron"
logwatch-cron kills.

cron tab logwatch --service="cron"

cat: cron.weekly: Is a directory
system cat failed: 256 at /usr/local/sbin/logwatch line 889.


Ann Hopkins wrote:
> SuSE 10.1
> Logwatch-CVS (Today)
> Cron (Standard) Updated
> Perl (/usr/local/bin)   5.8.8  (SOURCE INSTALL)
> /tmp - not executable
> 
> 
> I had a previous problem with an alternative "cron" called "fcron",
> so I returned to "cron".
> 
> I still have extremely weird problems occurring with the memory.
> I changed "logwatch.pl" and "Logwatch.pm" to refer to
> /usr/local/bin/perl.
> 
> I can not run the program in "cron", and when I immediately try to
> run it again from the command line it fails similarly with these
> kind of messages.  If I run it once again from the command line the
> problem disappears.
> 
> cat: cron.daily: Is a directory
> system cat failed: 256 at /usr/local/sbin/logwatch line 889.
> 
> It should not even see this directory.  It acts as if the working
> directory has somehow changed to the calling directory.
> 
> The directory is not always the same.  I confirmed "cat" works and
> is there.  It will go a partial run, but all the way.
> 
> Please help.  I really want "logwatch to run in "cron"  is there
> something particular I can look at.
> 
> Logwatch is not in the default directory structure, but I have
> always run it in a different area.
> 

_______________________________________________
Logwatch mailing list
Logwatch at logwatch.org
http://www2.list.logwatch.org:8080/lists/listinfo/logwatch

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFE9krwhs7JGk93PT0RAh/ZAKC6D14qlgy2Zn4X0vSvkmTEFVIgjgCfebkf
N6HDcFb8XhRAMziMYJkXuGg=
=e3UU
-----END PGP SIGNATURE-----



More information about the Logwatch mailing list