[Logwatch] logwatch is DOA - problem found

Dale Morin dale at mustanginternetservices.com
Fri Oct 3 05:21:02 MST 2008


I think I've tracked down the problem.  It is the ubuntu update to 
libc6, libc6-dev, and libc6-i686 that happened on Monday.

I loaded another machine with ubuntu 8.04, ran

"apt-get update"

and then

"apt-get install build-essential"

Installing build-essential installed updated libc files.  I then 
installed (or attempted to install) logwatch and the postfix config hung.

I started over and loaded another machine with ubuntu 8.04, ran

"apt-get update"

and then ran

"apt-get install libc6-dev=2.7-10ubuntu3"

so that the dev library was at the same version at libc6.  Then I placed 
all three libc6 packages on hold with

"echo -e "libc6 hold" | dpkg --set-selections"
"echo -e "libc6-dev hold" | dpkg --set-selections"
"echo -e "libc6-i686 hold" | dpkg --set-selections"

Then I ran

"apt-get install build-essential"

Afterweards, the libc6 libraries are still at 2.7-10ubuntu3 which is 
fine.  The problem version is 2.7-10ubuntu4 and it causes all kinds of 
problems.

I cannot seem to get the system running properly so I will have to wipe 
and start over, but I have the installed_packages file and good backups 
so it won't take too long.

Sincere thanks for all of those that helped me try and track down this 
problem.


-- 
Dale Morin, Mustang Internet Services, Inc.



More information about the Logwatch mailing list